Docker on Bhyve on FreeBSD
はじめに
Bhyveってなぁに?
Bhyveの設定
手順
1. pkg install vm-bhyve
2. zfs create pool/vm
3. sysrc vm_enable="YES"
4. sysrc vm_dir="zfs:pool/vm"
5. vm init
6. cp /usr/local/share/examples/vm-bhyve/* /mountpoint/for/pool/vm/.templates/
7. vm switch create public
8. vm switch add public em0
9. vm iso https://download.freebsd.org/ftp/releases/ISO-IMAGES/11.2/FreeBSD-11.2-RELEASE-amd64-bootonly.iso
10. vm create myguest
11. vm install [-f] myguest FreeBSD-11.2-RELEASE-amd64-bootonly.iso
12. vm console myguest
code:/boot/loader.conf
# Bhyve
vmm_load="YES"
nmdm_load="YES"
code:/etc/rc.conf
# Bhyve
vm_enable="YES"
vm_dir="zfs:zroot/vm"
Dockerのインストールと設定
code:shell
$ sudo vm start debian-k8s
Starting debian-k8s
* found guest in /zroot/vm/debian-k8s
* booting...
code:shell
$ sudo vm console debian-k8s
(snip)
code:shell
$ sudo apt-get remove docker docker-engine docker.io containerd runc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package 'docker-engine' is not installed, so not removed
E: Unable to locate package containerd
code:shell
$ sudo apt update
(snip)
$ sudo apt-get install apt-transport-https ca-certificates curl gnupg-agent software-properties-common
(snip)
code:shell
OK
$ sudo apt-key fingerprint 0EBFCD88
pub rsa4096 2017-02-22 SCEA 9DC8 5822 9FC7 DD38 854A E2D8 8D81 803C 0EBF CD88
uid unknown Docker Release (CE deb) <docker@docker.com> code:shell
$ sudo add-apt-repository \
$(lsb_release -cs) \
stable"
code:shell
$ sudo apt-get update
(snip)
$ sudo apt-get install docker-ce docker-ce-cli containerd.io
(snip)
code:shell
$ sudo docker run hello-world
Unable to find image 'hello-world:latest' locally
latest: Pulling from library/hello-world
0e03bdcc26d7: Pull complete
Digest: sha256:95ddb6c31407e84e91a986b004aee40975cb0bda14b5949f6faac5d2deadb4b9
Status: Downloaded newer image for hello-world:latest
Hello from Docker!
This message shows that your installation appears to be working correctly.
To generate this message, Docker took the following steps:
1. The Docker client contacted the Docker daemon.
2. The Docker daemon pulled the "hello-world" image from the Docker Hub.
(amd64)
3. The Docker daemon created a new container from that image which runs the
executable that produces the output you are currently reading.
4. The Docker daemon streamed that output to the Docker client, which sent it
to your terminal.
To try something more ambitious, you can run an Ubuntu container with:
$ docker run -it ubuntu bash
Share images, automate workflows, and more with a free Docker ID:
For more examples and ideas, visit:
code:shell
$ sudo usermod -aG docker mutoh
おわりに
参考文献